6301 C++ Programming Manual: D:/6301/Cpp Directory Reference

6301 C++ Programming Manual
Cpp Directory Reference

Files

file JY6301.h
@SectionBegin JY6301 FileHead
Generated by doxygen 1.9.1


6301 C++ Programming Manual: D:/6301/Cpp/JY6301.h File Reference

Typedefs | Enumerations | Functions
JY6301.h File Reference

@SectionBegin JY6301 FileHead More...

Typedefs

typedef void * JY6301_DeviceHandle
Windows. More...

Enumerations

enum | JY6301_AI_SampleMode { JY6301_AI_Finite = 0 , JY6301_AI_Continuous = 1 , JY6301_AI_Single = 2 }
enum | JY6301_AI_RTDTerminalType { JY6301_AI_2Wire = 0 , JY6301_AI_3Wire = 1 , JY6301_AI_4Wire = 2 }
enum JY6301_AI_RTDType {
JY6301_AI_TCR3851 = 0 , JY6301_AI_TCR3916 = 1 , JY6301_AI_TCR3920 = 2 , JY6301_AI_TCR3911 = 3 ,
JY6301_AI_TCR3928 = 4
}
enum | JY6301_AI_TriggerType { JY6301_AI_Immediately = 0 , JY6301_AI_Digital = 1 , JY6301_AI_Analog = 2 , JY6301_AI_Soft = 3 }
enum | JY6301_AI_TriggerMode { JY6301_AI_Trigger_Start = 0 , JY6301_AI_Trigger_Reference = 1 , JY6301_AI_Trigger_Advance = 2 }
enum | JY6301_DigitalTriggerEdge { JY6301_Rising = 0 , JY6301_Falling = 1 }
enum JY6301_IOTerminal {
JY6301_PFI_0 = 8 , JY6301_PFI_1 = 9 , JY6301_PFI_2 = 10 , JY6301_PFI_3 = 11 ,
JY6301_PFI_4 = 12 , JY6301_PFI_5 = 13 , JY6301_PFI_6 = 14 , JY6301_PFI_7 = 15 ,
JY6301_PXITrigger_0 = 16 , JY6301_PXITrigger_1 = 17 , JY6301_PXITrigger_2 = 18 , JY6301_PXITrigger_3 = 19 ,
JY6301_PXITrigger_4 = 20 , JY6301_PXITrigger_5 = 21 , JY6301_PXITrigger_6 = 22 , JY6301_PXITrigger_7 = 23 ,
JY6301_STAR = 7
}
enum | JY6301_Signal_Source { JY6301_AI_SampleClock = 1 , JY6301_AI_StartTrig = 25 , JY6301_AI_ReferenceTrig = 27 , JY6301_AI_AdvanceTrig = 29 }
enum JY6301_Signal_Destination {
JY6301_EXPORT_PFI_0 = 8 , JY6301_EXPORT_PFI_1 = 9 , JY6301_EXPORT_PFI_2 = 10 , JY6301_EXPORT_PFI_3 = 11 ,
JY6301_EXPORT_TriggerBus_0 = 16 , JY6301_EXPORT_TriggerBus_1 = 17 , JY6301_EXPORT_TriggerBus_2 = 18 , JY6301_EXPORT_TriggerBus_3 = 19 ,
JY6301_EXPORT_TriggerBus_4 = 20 , JY6301_EXPORT_TriggerBus_5 = 21 , JY6301_EXPORT_TriggerBus_6 = 22 , JY6301_EXPORT_TriggerBus_7 = 23 ,
JY6301_EXPORT_STAR = 7
}
enum | JY6301_SampleClockSource { JY6301_InternalSampleClock = 0 , JY6301_ExternalSampleClock = 1 }
enum | JY6301_ReferenceClock { JY6301_Internal = 0 , JY6301_PXIe_Clk100 = 1 }
enum | JY6301_ReadDataType { JY6301_ReadDataType_Resistance = 0 , JY6301_ReadDataType_Temperature = 1 }

Functions

JY6301API int | JY6301_Open (int slotNumber, JY6301_DeviceHandle *hDevice)
JY6301API int | JY6301_OpenByName (const char *cardName, JY6301_DeviceHandle *hDevice)
JY6301API int | JY6301_GetDeviceID (JY6301_DeviceHandle hDevice, int *deviceID)
Obtain the board ID. More...
JY6301API int | JY6301_GetDeviceSerialNumber (JY6301_DeviceHandle hDevice, char *serialNumber, int length)
Get the device serialNumber. More...
JY6301API int | JY6301_Close (JY6301_DeviceHandle hDevice)
JY6301API int | JY6301_AI_SetReadDataType (JY6301_DeviceHandle hDevice, JY6301_ReadDataType dataType)
JY6301API int | JY6301_AI_SetTerminalType (JY6301_DeviceHandle hDevice, JY6301_AI_RTDTerminalType terminalType)
JY6301API int | JY6301_AI_SetRTDType (JY6301_DeviceHandle hDevice, JY6301_AI_RTDType type)
JY6301API int | JY6301_AI_EnableChannel (JY6301_DeviceHandle hDevice, unsigned int channelsCount, unsigned int *channelsIndex, double *maxResistanceRange)
JY6301API int | JY6301_AI_SetExternalSampleClockTerminal (JY6301_DeviceHandle hDevice, JY6301_IOTerminal extSampleClkSrc)
JY6301API int | JY6301_AI_SetSampleRate (JY6301_DeviceHandle hDevice, double sampleRate, int REJ60, JY6301_SampleClockSource sampleClkSrc, double *actualSampleRate, int *powerLineRejEnabled)
JY6301API int | JY6301_AI_GetActualSampleRate (double sampleRate, int REJ60, JY6301_AI_RTDTerminalType terminalType, unsigned int *chIndex, unsigned int chCount, double *actualSampleRate, int *powerLineRejEnabled)
JY6301API int | JY6301_AI_SetSamplesToAcquire (JY6301_DeviceHandle hDevice, unsigned int samplesToAcquire)
JY6301API int | JY6301_AI_SetSampleMode (JY6301_DeviceHandle hDevice, JY6301_AI_SampleMode mode)
JY6301API int | JY6301_AI_Start (JY6301_DeviceHandle hDevice)
JY6301API int | JY6301_AI_Stop (JY6301_DeviceHandle hDevice)
JY6301API int | JY6301_AI_ReadRawData (JY6301_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
JY6301API int | JY6301_AI_ReadData (JY6301_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
JY6301API int | JY6301_AI_ReadSinglePoint (JY6301_DeviceHandle hDevice, double *dataBuffer, int channelID)
JY6301API int | JY6301_AI_WaitUntilDone (JY6301_DeviceHandle hDevice, int timeout, bool *done)
JY6301API int | JY6301_AI_SetBufferSize (JY6301_DeviceHandle hDevice, unsigned long bufferSize)
JY6301API int | JY6301_AI_CheckBufferStatus (JY6301_DeviceHandle hDevice, unsigned long long *availableSamplesCount, bool *overflow)
Check AI device buffer status. More...
JY6301API int | JY6301_AI_CheckBufferStatusEx (JY6301_DeviceHandle hDevice, unsigned long long *availableSamplesCount, unsigned long long *transferedSamples, bool *overflow)
Check AI device buffer status. More...
JY6301API int | JY6301_AI_SetStartTriggerType (JY6301_DeviceHandle hDevice, JY6301_AI_TriggerType triggerType)
JY6301API int | JY6301_AI_SetDigitalStartTrigger (JY6301_DeviceHandle hDevice, JY6301_IOTerminal triggerSource, JY6301_DigitalTriggerEdge triggerEdge)
JY6301API int | JY6301_AI_SetReferenceTriggerType (JY6301_DeviceHandle hDevice, JY6301_AI_TriggerType triggerType)
JY6301API int | JY6301_AI_SetDigitalReferenceTrigger (JY6301_DeviceHandle hDevice, JY6301_IOTerminal triggerSource, JY6301_DigitalTriggerEdge triggerEdge)
JY6301API int | JY6301_AI_SetAdvanceTriggerType (JY6301_DeviceHandle hDevice, JY6301_AI_TriggerType triggerType)
JY6301API int | JY6301_AI_SetDigitalAdvanceTrigger (JY6301_DeviceHandle hDevice, JY6301_IOTerminal triggerSource, JY6301_DigitalTriggerEdge triggerEdge)
JY6301API int | JY6301_AI_SetPreTriggerSamples (JY6301_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0. More...
JY6301API int | JY6301_AI_SetReTriggerCount (JY6301_DeviceHandle hDevice, unsigned int reTriggerCount)
Set AI retrigger count. More...
JY6301API int | JY6301_AI_SendSoftTrigger (JY6301_DeviceHandle hDevice, JY6301_AI_TriggerMode triggerMode)
JY6301API int | JY6301_AI_PerformOpenWireDetection (JY6301_DeviceHandle hDevice, int *data, int *convError, int *refError)
JY6301API int | JY6301_SignalRouting (JY6301_DeviceHandle hDevice, JY6301_Signal_Destination destination, JY6301_Signal_Source source)
JY6301API int | JY6301_DisconnectSignalRouting (JY6301_DeviceHandle hDevice, JY6301_Signal_Destination destination)

Detailed Description

@SectionBegin JY6301 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2021, JYTEK
All rights reserved.
Author
JYTEK
Version
3.2.0
Date
2022-6-24

This header file defines C/C++ API and enums used in the JY6301 driver.

Revision Notes:

Typedef Documentation

◆ JY6301_DeviceHandle

typedef void* JY6301_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY6301_AI_RTDTerminalType

enum JY6301_AI_RTDTerminalType
Enumerator
JY6301_AI_2Wire | AI 2WireRTD Terminal.
JY6301_AI_3Wire | AI 3WireRTD Terminal.
JY6301_AI_4Wire | AI 4WireRTD Terminal.

◆ JY6301_AI_RTDType

enum JY6301_AI_RTDType
Enumerator
JY6301_AI_TCR3851 | RTD TCR = 3851 (Default)
JY6301_AI_TCR3916 | RTD TCR = 3916.
JY6301_AI_TCR3920 | RTD TCR = 3920.
JY6301_AI_TCR3911 | RTD TCR = 3911.
JY6301_AI_TCR3928 | RTD TCR = 3928.

◆ JY6301_AI_SampleMode

enum JY6301_AI_SampleMode
Enumerator
JY6301_AI_Finite | AI Finite Mode.
JY6301_AI_Continuous | AI Continuous Mode.
JY6301_AI_Single | AI Single Mode.

◆ JY6301_AI_TriggerMode

enum JY6301_AI_TriggerMode
Enumerator
JY6301_AI_Trigger_Start | AI Start Trigger Mode.
JY6301_AI_Trigger_Reference | AI Reference Trigger Mode.
JY6301_AI_Trigger_Advance | AI Advance Trigger Mode.

◆ JY6301_AI_TriggerType

enum JY6301_AI_TriggerType
Enumerator
JY6301_AI_Immediately | AI Immediately Trigger.
JY6301_AI_Digital | AI Digital Trigger.
JY6301_AI_Analog | AI Analog Trigger.
JY6301_AI_Soft | AI Soft Trigger.

◆ JY6301_DigitalTriggerEdge

enum JY6301_DigitalTriggerEdge
Enumerator
JY6301_Rising | AI Rising edge for digital trigger.
JY6301_Falling | AI Falling edge for digital trigger.

◆ JY6301_IOTerminal

enum JY6301_IOTerminal
Enumerator
JY6301_PFI_0 | PFI0 as the terminal.
JY6301_PFI_1 | PFI1 as the terminal.
JY6301_PFI_2 | PFI2 as the terminal.
JY6301_PFI_3 | PFI3 as the terminal.
JY6301_PFI_4 | PFI4 as the terminal.
JY6301_PFI_5 | PFI5 as the terminal.
JY6301_PFI_6 | PFI6 as the terminal.
JY6301_PFI_7 | PFI7 as the terminal.
JY6301_PXITrigger_0 | PXITrigger0 as the terminal.
JY6301_PXITrigger_1 | PXITrigger1 as the terminal.
JY6301_PXITrigger_2 | PXITrigger2 as the terminal.
JY6301_PXITrigger_3 | PXITrigger3 as the terminal.
JY6301_PXITrigger_4 | PXITrigger4 as the terminal.
JY6301_PXITrigger_5 | PXITrigger5 as the terminal.
JY6301_PXITrigger_6 | PXITrigger6 as the terminal.
JY6301_PXITrigger_7 | PXITrigger7 as the terminal.
JY6301_STAR | STAR as the terminal.

◆ JY6301_ReadDataType

enum JY6301_ReadDataType
Enumerator
JY6301_ReadDataType_Resistance | AI Resistance Measure.
JY6301_ReadDataType_Temperature | AI Temperature Measure.

◆ JY6301_ReferenceClock

enum JY6301_ReferenceClock
Enumerator
JY6301_Internal | AI Internal ReferenceClock.
JY6301_PXIe_Clk100 | The PXIe chassis 100MHz JY6301_ReferenceClock, only for PXIe module.

◆ JY6301_SampleClockSource

enum JY6301_SampleClockSource
Enumerator
JY6301_InternalSampleClock | AI Internal SampleClock.
JY6301_ExternalSampleClock | AI External SampleClock.

◆ JY6301_Signal_Destination

enum JY6301_Signal_Destination
Enumerator
JY6301_EXPORT_PFI_0 | EXPORT_PFI_0 as the signal desition to rout.
JY6301_EXPORT_PFI_1 | EXPORT_PFI_1 as the signal desition to rout.
JY6301_EXPORT_PFI_2 | EXPORT_PFI_2 as the signal desition to rout.
JY6301_EXPORT_PFI_3 | EXPORT_PFI_3 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_0 | EXPORT_TriggerBus_0 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_1 | EXPORT_TriggerBus_1 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_2 | EXPORT_TriggerBus_2 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_3 | EXPORT_TriggerBus_3 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_4 | EXPORT_TriggerBus_4 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_5 | EXPORT_TriggerBus_5 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_6 | EXPORT_TriggerBus_6 as the signal desition to rout.
JY6301_EXPORT_TriggerBus_7 | EXPORT_TriggerBus_7 as the signal desition to rout.
JY6301_EXPORT_STAR | EXPORT_STAR as the signal desition to rout.

◆ JY6301_Signal_Source

enum JY6301_Signal_Source
Enumerator
JY6301_AI_SampleClock | AI_SampleClock as the source signal to rout.
JY6301_AI_StartTrig | AI_StartTrig as the source signal to rout.
JY6301_AI_ReferenceTrig | AI_ReferenceTrig as the source signal to rout.
JY6301_AI_AdvanceTrig | AI_AdvanceTrig as the source signal to rout.

Function Documentation

◆ JY6301_AI_CheckBufferStatus()

JY6301API int JY6301_AI_CheckBufferStatus | ( | JY6301_DeviceHandle | hDevice,
 |  | unsigned long long * | availableSamplesCount,
 |  | bool * | overflow
 | ) |  |

Check AI device buffer status.

This API is intended to be compatible with older version drivers,It is recommended to use API JY6301_AI_CheckBufferStatusEx. /summary> param name="hDevice">device handle

param name="availableSamplesCount">number of samples per channel in the device buffer

param name="overflow">true:overflow, false: not overflow.

returns>0 if success or other error code

◆ JY6301_AI_CheckBufferStatusEx()

JY6301API int JY6301_AI_CheckBufferStatusEx | ( | JY6301_DeviceHandle | hDevice,
 |  | unsigned long long * | availableSamplesCount,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overflow
 | ) |  |

Check AI device buffer status.

/summary> param name="hDevice">device handle

param name="availableSamplesCount">number of samples per channel in the device buffer

param name="transferedSamples">The number of samples that have been transfered from the device buffer (per channel)

param name="overflow">true:overflow, false: not overflow.

returns>0 if success or other error code

◆ JY6301_AI_EnableChannel()

JY6301API int JY6301_AI_EnableChannel | ( | JY6301_DeviceHandle | hDevice,
 |  | unsigned int | channelsCount,
 |  | unsigned int * | channelsIndex,
 |  | double * | maxResistanceRange
 | ) |  |

◆ JY6301_AI_GetActualSampleRate()

JY6301API int JY6301_AI_GetActualSampleRate | ( | double | sampleRate,
 |  | int | REJ60,
 |  | JY6301_AI_RTDTerminalType | terminalType,
 |  | unsigned int * | chIndex,
 |  | unsigned int | chCount,
 |  | double * | actualSampleRate,
 |  | int * | powerLineRejEnabled
 | ) |  |

summary> Trial calculation of the sampling rate to obtain the actual sampling rate. /summary> param name="sampleRate">up to 800Sa/s can be set on each AD chip

param name="REJ60">0: prefer 50Hz power line rejection. 1: prefer 60Hz power line rejection. Valid when the total sampling rate is less than or equal to 40Sa/s.

param name="terminalType">RTD terminal type (2-wire/3-wire/4-wire). 32 channels available when 2-wire or 3-wire is selected; 20 channels available when 4-wire is selected.

param name="chIndex">physical serial number of the chCount array

param name="chCount">wether power line rejection enabled

param name="actualSampleRate">actual sampling rate set by this device,which may be different from the desired sampleRate

param name="powerLineRejEnabled">wether power line rejection enabled

Returns
0 if success or other error code

◆ JY6301_AI_PerformOpenWireDetection()

JY6301API int JY6301_AI_PerformOpenWireDetection | ( | JY6301_DeviceHandle | hDevice,
 |  | int * | data,
 |  | int * | convError,
 |  | int * | refError
 | ) |  |

◆ JY6301_AI_ReadData()

JY6301API int JY6301_AI_ReadData | ( | JY6301_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

◆ JY6301_AI_ReadRawData()

JY6301API int JY6301_AI_ReadRawData | ( | JY6301_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

◆ JY6301_AI_ReadSinglePoint()

JY6301API int JY6301_AI_ReadSinglePoint | ( | JY6301_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | int | channelID
 | ) |  |

◆ JY6301_AI_SendSoftTrigger()

JY6301API int JY6301_AI_SendSoftTrigger | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_AI_TriggerMode | triggerMode
 | ) |  |

◆ JY6301_AI_SetAdvanceTriggerType()

JY6301API int JY6301_AI_SetAdvanceTriggerType | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_AI_TriggerType | triggerType
 | ) |  |

◆ JY6301_AI_SetBufferSize()

JY6301API int JY6301_AI_SetBufferSize | ( | JY6301_DeviceHandle | hDevice,
 |  | unsigned long | bufferSize
 | ) |  |

◆ JY6301_AI_SetDigitalAdvanceTrigger()

JY6301API int JY6301_AI_SetDigitalAdvanceTrigger | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_IOTerminal | triggerSource,
 |  | JY6301_DigitalTriggerEdge | triggerEdge
 | ) |  |

◆ JY6301_AI_SetDigitalReferenceTrigger()

JY6301API int JY6301_AI_SetDigitalReferenceTrigger | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_IOTerminal | triggerSource,
 |  | JY6301_DigitalTriggerEdge | triggerEdge
 | ) |  |

◆ JY6301_AI_SetDigitalStartTrigger()

JY6301API int JY6301_AI_SetDigitalStartTrigger | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_IOTerminal | triggerSource,
 |  | JY6301_DigitalTriggerEdge | triggerEdge
 | ) |  |

◆ JY6301_AI_SetExternalSampleClockTerminal()

JY6301API int JY6301_AI_SetExternalSampleClockTerminal | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_IOTerminal | extSampleClkSrc
 | ) |  |

◆ JY6301_AI_SetPreTriggerSamples()

JY6301API int JY6301_AI_SetPreTriggerSamples | ( | JY6301_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY6301_AI_SetReadDataType()

JY6301API int JY6301_AI_SetReadDataType | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_ReadDataType | dataType
 | ) |  |

◆ JY6301_AI_SetReferenceTriggerType()

JY6301API int JY6301_AI_SetReferenceTriggerType | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_AI_TriggerType | triggerType
 | ) |  |

◆ JY6301_AI_SetReTriggerCount()

JY6301API int JY6301_AI_SetReTriggerCount | ( | JY6301_DeviceHandle | hDevice,
 |  | unsigned int | reTriggerCount
 | ) |  |

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY6301_AI_SetRTDType()

JY6301API int JY6301_AI_SetRTDType | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_AI_RTDType | type
 | ) |  |

◆ JY6301_AI_SetSampleMode()

JY6301API int JY6301_AI_SetSampleMode | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_AI_SampleMode | mode
 | ) |  |

◆ JY6301_AI_SetSampleRate()

JY6301API int JY6301_AI_SetSampleRate | ( | JY6301_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | int | REJ60,
 |  | JY6301_SampleClockSource | sampleClkSrc,
 |  | double * | actualSampleRate,
 |  | int * | powerLineRejEnabled
 | ) |  |

summary> Set sampling rate. The sampling rate is the same for all channels. /summary> param name="hDevice">device handle

param name="sampleRate">up to 800Sa/s can be set on each AD chip

param name="REJ60">0: prefer 50Hz power line rejection. 1: prefer 60Hz power line rejection. Valid when the total sampling rate is less than or equal to 40Sa/s.

param name="sampleClkSrc">sample clock source.

param name="actualSampleRate">actual sampling rate set by this device,which may be different from the desired sampleRate

param name="powerLineRejEnabled">wether power line rejection enabled

Returns
0 if success or other error code

◆ JY6301_AI_SetSamplesToAcquire()

JY6301API int JY6301_AI_SetSamplesToAcquire | ( | JY6301_DeviceHandle | hDevice,
 |  | unsigned int | samplesToAcquire
 | ) |  |

◆ JY6301_AI_SetStartTriggerType()

JY6301API int JY6301_AI_SetStartTriggerType | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_AI_TriggerType | triggerType
 | ) |  |

◆ JY6301_AI_SetTerminalType()

JY6301API int JY6301_AI_SetTerminalType | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_AI_RTDTerminalType | terminalType
 | ) |  |

◆ JY6301_AI_Start()

JY6301API int JY6301_AI_Start ( JY6301_DeviceHandle hDevice )

◆ JY6301_AI_Stop()

JY6301API int JY6301_AI_Stop ( JY6301_DeviceHandle hDevice )

◆ JY6301_AI_WaitUntilDone()

JY6301API int JY6301_AI_WaitUntilDone | ( | JY6301_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | done
 | ) |  |

◆ JY6301_Close()

JY6301API int JY6301_Close ( JY6301_DeviceHandle hDevice )

◆ JY6301_DisconnectSignalRouting()

JY6301API int JY6301_DisconnectSignalRouting | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_Signal_Destination | destination
 | ) |  |

◆ JY6301_GetDeviceID()

JY6301API int JY6301_GetDeviceID | ( | JY6301_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the board ID.

The 6301 is a series of boards. The PXIe-6301 board ID is Ox6301 The PCIe-6301 board ID is OxA301 The USB-6301 board ID is OxB301

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY6301_GetDeviceSerialNumber()

JY6301API int JY6301_GetDeviceSerialNumber | ( | JY6301_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Get the device serialNumber.

/summary> param name="hDevice">device handle

param name="serialNumber">Pointer to a buffer receiving the serial number. The length of the serial number is 10.

param name="length">serial Number length ,length is 10

returns>0 if success or other error code

◆ JY6301_Open()

JY6301API int JY6301_Open | ( | int | slotNumber,
 |  | JY6301_DeviceHandle * | hDevice
 | ) |  |

◆ JY6301_OpenByName()

JY6301API int JY6301_OpenByName | ( | const char * | cardName,
 |  | JY6301_DeviceHandle * | hDevice
 | ) |  |

◆ JY6301_SignalRouting()

JY6301API int JY6301_SignalRouting | ( | JY6301_DeviceHandle | hDevice,
 |  | JY6301_Signal_Destination | destination,
 |  | JY6301_Signal_Source | source
 | ) |  |


6301 C++ Programming Manual: D:/6301 Directory Reference

  • D:
  • 6301
6301 Directory Reference

Directories

directory Cpp


6301 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 6301


6301 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D: |
▼ 6301 |
▼ Cpp |
JY6301.h | @SectionBegin JY6301 FileHead


6301 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY6301_AI_2Wire : JY6301.h
  • JY6301_AI_3Wire : JY6301.h
  • JY6301_AI_4Wire : JY6301.h
  • JY6301_AI_AdvanceTrig : JY6301.h
  • JY6301_AI_Analog : JY6301.h
  • JY6301_AI_CheckBufferStatus() : JY6301.h
  • JY6301_AI_CheckBufferStatusEx() : JY6301.h
  • JY6301_AI_Continuous : JY6301.h
  • JY6301_AI_Digital : JY6301.h
  • JY6301_AI_EnableChannel() : JY6301.h
  • JY6301_AI_Finite : JY6301.h
  • JY6301_AI_GetActualSampleRate() : JY6301.h
  • JY6301_AI_Immediately : JY6301.h
  • JY6301_AI_PerformOpenWireDetection() : JY6301.h
  • JY6301_AI_ReadData() : JY6301.h
  • JY6301_AI_ReadRawData() : JY6301.h
  • JY6301_AI_ReadSinglePoint() : JY6301.h
  • JY6301_AI_ReferenceTrig : JY6301.h
  • JY6301_AI_RTDTerminalType : JY6301.h
  • JY6301_AI_RTDType : JY6301.h
  • JY6301_AI_SampleClock : JY6301.h
  • JY6301_AI_SampleMode : JY6301.h
  • JY6301_AI_SendSoftTrigger() : JY6301.h
  • JY6301_AI_SetAdvanceTriggerType() : JY6301.h
  • JY6301_AI_SetBufferSize() : JY6301.h
  • JY6301_AI_SetDigitalAdvanceTrigger() : JY6301.h
  • JY6301_AI_SetDigitalReferenceTrigger() : JY6301.h
  • JY6301_AI_SetDigitalStartTrigger() : JY6301.h
  • JY6301_AI_SetExternalSampleClockTerminal() : JY6301.h
  • JY6301_AI_SetPreTriggerSamples() : JY6301.h
  • JY6301_AI_SetReadDataType() : JY6301.h
  • JY6301_AI_SetReferenceTriggerType() : JY6301.h
  • JY6301_AI_SetReTriggerCount() : JY6301.h
  • JY6301_AI_SetRTDType() : JY6301.h
  • JY6301_AI_SetSampleMode() : JY6301.h
  • JY6301_AI_SetSampleRate() : JY6301.h
  • JY6301_AI_SetSamplesToAcquire() : JY6301.h
  • JY6301_AI_SetStartTriggerType() : JY6301.h
  • JY6301_AI_SetTerminalType() : JY6301.h
  • JY6301_AI_Single : JY6301.h
  • JY6301_AI_Soft : JY6301.h
  • JY6301_AI_Start() : JY6301.h
  • JY6301_AI_StartTrig : JY6301.h
  • JY6301_AI_Stop() : JY6301.h
  • JY6301_AI_TCR3851 : JY6301.h
  • JY6301_AI_TCR3911 : JY6301.h
  • JY6301_AI_TCR3916 : JY6301.h
  • JY6301_AI_TCR3920 : JY6301.h
  • JY6301_AI_TCR3928 : JY6301.h
  • JY6301_AI_Trigger_Advance : JY6301.h
  • JY6301_AI_Trigger_Reference : JY6301.h
  • JY6301_AI_Trigger_Start : JY6301.h
  • JY6301_AI_TriggerMode : JY6301.h
  • JY6301_AI_TriggerType : JY6301.h
  • JY6301_AI_WaitUntilDone() : JY6301.h
  • JY6301_Close() : JY6301.h
  • JY6301_DeviceHandle : JY6301.h
  • JY6301_DigitalTriggerEdge : JY6301.h
  • JY6301_DisconnectSignalRouting() : JY6301.h
  • JY6301_EXPORT_PFI_0 : JY6301.h
  • JY6301_EXPORT_PFI_1 : JY6301.h
  • JY6301_EXPORT_PFI_2 : JY6301.h
  • JY6301_EXPORT_PFI_3 : JY6301.h
  • JY6301_EXPORT_STAR : JY6301.h
  • JY6301_EXPORT_TriggerBus_0 : JY6301.h
  • JY6301_EXPORT_TriggerBus_1 : JY6301.h
  • JY6301_EXPORT_TriggerBus_2 : JY6301.h
  • JY6301_EXPORT_TriggerBus_3 : JY6301.h
  • JY6301_EXPORT_TriggerBus_4 : JY6301.h
  • JY6301_EXPORT_TriggerBus_5 : JY6301.h
  • JY6301_EXPORT_TriggerBus_6 : JY6301.h
  • JY6301_EXPORT_TriggerBus_7 : JY6301.h
  • JY6301_ExternalSampleClock : JY6301.h
  • JY6301_Falling : JY6301.h
  • JY6301_GetDeviceID() : JY6301.h
  • JY6301_GetDeviceSerialNumber() : JY6301.h
  • JY6301_Internal : JY6301.h
  • JY6301_InternalSampleClock : JY6301.h
  • JY6301_IOTerminal : JY6301.h
  • JY6301_Open() : JY6301.h
  • JY6301_OpenByName() : JY6301.h
  • JY6301_PFI_0 : JY6301.h
  • JY6301_PFI_1 : JY6301.h
  • JY6301_PFI_2 : JY6301.h
  • JY6301_PFI_3 : JY6301.h
  • JY6301_PFI_4 : JY6301.h
  • JY6301_PFI_5 : JY6301.h
  • JY6301_PFI_6 : JY6301.h
  • JY6301_PFI_7 : JY6301.h
  • JY6301_PXIe_Clk100 : JY6301.h
  • JY6301_PXITrigger_0 : JY6301.h
  • JY6301_PXITrigger_1 : JY6301.h
  • JY6301_PXITrigger_2 : JY6301.h
  • JY6301_PXITrigger_3 : JY6301.h
  • JY6301_PXITrigger_4 : JY6301.h
  • JY6301_PXITrigger_5 : JY6301.h
  • JY6301_PXITrigger_6 : JY6301.h
  • JY6301_PXITrigger_7 : JY6301.h
  • JY6301_ReadDataType : JY6301.h
  • JY6301_ReadDataType_Resistance : JY6301.h
  • JY6301_ReadDataType_Temperature : JY6301.h
  • JY6301_ReferenceClock : JY6301.h
  • JY6301_Rising : JY6301.h
  • JY6301_SampleClockSource : JY6301.h
  • JY6301_Signal_Destination : JY6301.h
  • JY6301_Signal_Source : JY6301.h
  • JY6301_SignalRouting() : JY6301.h
  • JY6301_STAR : JY6301.h


6301 C++ Programming Manual: File Members

  • JY6301_AI_RTDTerminalType : JY6301.h
  • JY6301_AI_RTDType : JY6301.h
  • JY6301_AI_SampleMode : JY6301.h
  • JY6301_AI_TriggerMode : JY6301.h
  • JY6301_AI_TriggerType : JY6301.h
  • JY6301_DigitalTriggerEdge : JY6301.h
  • JY6301_IOTerminal : JY6301.h
  • JY6301_ReadDataType : JY6301.h
  • JY6301_ReferenceClock : JY6301.h
  • JY6301_SampleClockSource : JY6301.h
  • JY6301_Signal_Destination : JY6301.h
  • JY6301_Signal_Source : JY6301.h


6301 C++ Programming Manual: File Members

- j -

  • JY6301_AI_2Wire : JY6301.h
  • JY6301_AI_3Wire : JY6301.h
  • JY6301_AI_4Wire : JY6301.h
  • JY6301_AI_AdvanceTrig : JY6301.h
  • JY6301_AI_Analog : JY6301.h
  • JY6301_AI_Continuous : JY6301.h
  • JY6301_AI_Digital : JY6301.h
  • JY6301_AI_Finite : JY6301.h
  • JY6301_AI_Immediately : JY6301.h
  • JY6301_AI_ReferenceTrig : JY6301.h
  • JY6301_AI_SampleClock : JY6301.h
  • JY6301_AI_Single : JY6301.h
  • JY6301_AI_Soft : JY6301.h
  • JY6301_AI_StartTrig : JY6301.h
  • JY6301_AI_TCR3851 : JY6301.h
  • JY6301_AI_TCR3911 : JY6301.h
  • JY6301_AI_TCR3916 : JY6301.h
  • JY6301_AI_TCR3920 : JY6301.h
  • JY6301_AI_TCR3928 : JY6301.h
  • JY6301_AI_Trigger_Advance : JY6301.h
  • JY6301_AI_Trigger_Reference : JY6301.h
  • JY6301_AI_Trigger_Start : JY6301.h
  • JY6301_EXPORT_PFI_0 : JY6301.h
  • JY6301_EXPORT_PFI_1 : JY6301.h
  • JY6301_EXPORT_PFI_2 : JY6301.h
  • JY6301_EXPORT_PFI_3 : JY6301.h
  • JY6301_EXPORT_STAR : JY6301.h
  • JY6301_EXPORT_TriggerBus_0 : JY6301.h
  • JY6301_EXPORT_TriggerBus_1 : JY6301.h
  • JY6301_EXPORT_TriggerBus_2 : JY6301.h
  • JY6301_EXPORT_TriggerBus_3 : JY6301.h
  • JY6301_EXPORT_TriggerBus_4 : JY6301.h
  • JY6301_EXPORT_TriggerBus_5 : JY6301.h
  • JY6301_EXPORT_TriggerBus_6 : JY6301.h
  • JY6301_EXPORT_TriggerBus_7 : JY6301.h
  • JY6301_ExternalSampleClock : JY6301.h
  • JY6301_Falling : JY6301.h
  • JY6301_Internal : JY6301.h
  • JY6301_InternalSampleClock : JY6301.h
  • JY6301_PFI_0 : JY6301.h
  • JY6301_PFI_1 : JY6301.h
  • JY6301_PFI_2 : JY6301.h
  • JY6301_PFI_3 : JY6301.h
  • JY6301_PFI_4 : JY6301.h
  • JY6301_PFI_5 : JY6301.h
  • JY6301_PFI_6 : JY6301.h
  • JY6301_PFI_7 : JY6301.h
  • JY6301_PXIe_Clk100 : JY6301.h
  • JY6301_PXITrigger_0 : JY6301.h
  • JY6301_PXITrigger_1 : JY6301.h
  • JY6301_PXITrigger_2 : JY6301.h
  • JY6301_PXITrigger_3 : JY6301.h
  • JY6301_PXITrigger_4 : JY6301.h
  • JY6301_PXITrigger_5 : JY6301.h
  • JY6301_PXITrigger_6 : JY6301.h
  • JY6301_PXITrigger_7 : JY6301.h
  • JY6301_ReadDataType_Resistance : JY6301.h
  • JY6301_ReadDataType_Temperature : JY6301.h
  • JY6301_Rising : JY6301.h
  • JY6301_STAR : JY6301.h


6301 C++ Programming Manual: File Members

- j -

  • JY6301_AI_CheckBufferStatus() : JY6301.h
  • JY6301_AI_CheckBufferStatusEx() : JY6301.h
  • JY6301_AI_EnableChannel() : JY6301.h
  • JY6301_AI_GetActualSampleRate() : JY6301.h
  • JY6301_AI_PerformOpenWireDetection() : JY6301.h
  • JY6301_AI_ReadData() : JY6301.h
  • JY6301_AI_ReadRawData() : JY6301.h
  • JY6301_AI_ReadSinglePoint() : JY6301.h
  • JY6301_AI_SendSoftTrigger() : JY6301.h
  • JY6301_AI_SetAdvanceTriggerType() : JY6301.h
  • JY6301_AI_SetBufferSize() : JY6301.h
  • JY6301_AI_SetDigitalAdvanceTrigger() : JY6301.h
  • JY6301_AI_SetDigitalReferenceTrigger() : JY6301.h
  • JY6301_AI_SetDigitalStartTrigger() : JY6301.h
  • JY6301_AI_SetExternalSampleClockTerminal() : JY6301.h
  • JY6301_AI_SetPreTriggerSamples() : JY6301.h
  • JY6301_AI_SetReadDataType() : JY6301.h
  • JY6301_AI_SetReferenceTriggerType() : JY6301.h
  • JY6301_AI_SetReTriggerCount() : JY6301.h
  • JY6301_AI_SetRTDType() : JY6301.h
  • JY6301_AI_SetSampleMode() : JY6301.h
  • JY6301_AI_SetSampleRate() : JY6301.h
  • JY6301_AI_SetSamplesToAcquire() : JY6301.h
  • JY6301_AI_SetStartTriggerType() : JY6301.h
  • JY6301_AI_SetTerminalType() : JY6301.h
  • JY6301_AI_Start() : JY6301.h
  • JY6301_AI_Stop() : JY6301.h
  • JY6301_AI_WaitUntilDone() : JY6301.h
  • JY6301_Close() : JY6301.h
  • JY6301_DisconnectSignalRouting() : JY6301.h
  • JY6301_GetDeviceID() : JY6301.h
  • JY6301_GetDeviceSerialNumber() : JY6301.h
  • JY6301_Open() : JY6301.h
  • JY6301_OpenByName() : JY6301.h
  • JY6301_SignalRouting() : JY6301.h


6301 C++ Programming Manual: File Members

  • JY6301_DeviceHandle : JY6301.h


6301 C++ Programming Manual: Main Page

6301 C++ Programming Manual Documentation